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Disclaimer 

Whilst reasonable efforts have been made to ensure the accuracy of the information contained in this publication (Reference 
Materials), the CIC nevertheless encourages readers to seek appropriate independent advice from their professional advisers where 

possible. Readers should not treat or rely on this publication (Reference Materials) as a substitute for such professional advice. 
 
 

Enquiries 
Enquiries on the Reference Materials may be made to the CIC Secretariat: 

CIC Headquarters 
38/F, COS Centre, 56 Tsun Yip Street, 

Kwun Tong, Kowloon 
 

Tel: (852) 2100 9000 
Fax: (852) 2100 9090 
Email: enquiry@cic.hk 
Website: www.cic.hk 

 
 

© 2021 Construction Industry Council. 
 
 
 
 

Copyright Notice 
 

This User Guide will only become truly useful if as many companies adopt it as possible. To that extent, it may be freely 
distributed and used in any format necessary, provided credit is given to the CIC. 
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1 Hardware / System Requirements 

1.1 General 
Hardware / system requirements for modelling, coordination and visualisation on desktop/notebook 
computers and mobile devices should be determined by the BIM managers for different projects on 
a case by case basis. The minimum requirement varies for different applications, project sizes and 
operating systems. 
https://www.autodesk.com/collections/architecture-engineering-construction/included-
software 
 
 

https://www.autodesk.com/collections/architecture-engineering-construction/included-software
https://www.autodesk.com/collections/architecture-engineering-construction/included-software
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2 Revit Basics 

2.1 User Interface 
Open a project or family or create either one from a template to get started. The user interface 
provides the tools need to work in a model. The user interface can customise the interface to 
support the way for different works. 
 
Project Browser: organise the views, schedules, and sheets of the current project. 

 
 
 Properties palette: modify properties of selected elements. 
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 Ribbon: select the tools needed to design the building model. 

 
 
 View Control Bar: provide options for changing the scale, view display, including scale or 

visual style. 
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2.2 Difference of RVT, RTE, and RFA files 
It will eventually become necessary to save our work and share our progress with others in the 
model.  
 
 RTEs are project template files.  
 RVTs are working project files. Both files can be generated from Revit® projects. The 

difference is that the template is used when you start a new project. 
 RFAs are family files that can either be loaded into a project or saved externally. 

 

2.3 Types of Family (system families, loadable families, and 
in-place families) 
BIM object in Revit calls as a family. There are three types of families in the model, which are 
system families, loadable families and in-place families. 
 

2.3.1 System Families 
System families are basic elements to the assembly on a construction site. It can be predefined in 
the model, for example: duct, pipe, cable tray, conduit etc. 
 
Remarks:  
There is no system family for trunking in Revit. In practice, duct with different system names and 
the setting is used to imitate trunking in Revit environment. 
OR 
To maintain the electrical properties of the “trunking” element, you are advised to prepare the 
“trunking” by using a cable tray with a different type name and setting. The geometry (size) of the 
trunking could serve 3D coordination. However, it could not reflect the realistic 3D presentation. 
 

2.3.2 Loadable Families 
Loadable families are families used to create customised components such as fitting, valves, 
lighting, pump, and chiller. It includes customisation of annotation elements, such as symbols and 
title blocks. 
 

2.3.3 In-Place Families 
In-place elements are unique elements for a specific project. It can be created in-place geometry or 
imported to other projects to resize the shape. However, in-place families should be avoided as 
much as possible, except for custom components generally built “on site” or for building massing 
during design.  
 



 

11 

R
evit B

asics 

2.4 Categories and Types 
Category assigns the properties of a predefined family category to the component. Assignment of 
category should be referred to the CIC’s Master list of ‘Category’ and ‘Functional Type’ (also 
known as ‘Cat-Code’ and ‘Sub-Cat Code’) of BIM object. 
 
Types define components that apply across all types in that family. 
 

2.5 Parameters 
 
Technically in Revit, there are four (4) types of parameters that can be identified which are Project, 
Built-in, Family Parameters and Shared Project Parameters. The details of each are presented 
below. 
 
Project Parameters The parameters are created by the user and able to add multiple 

categories of elements in a project. 
Built-In Parameters The parameters are the default setting when creating a new 

family. This cannot be customised or changed accordingly. 
Family Parameters The user may create the parameter to help in controlling the 

parametric object within the family. However, It can be custom as 
a type or an instance property of a family but cannot be used for 
scheduling or tagging purposes. 

Shared Project Parameters Similar to family parameters but they are created within the 
“Shared Parameter List” and can be used for scheduling and 
tagging purposes. 
It is strongly recommended to prepare for the common 
parameters, such as “Width”, “Length”, “Symbol_Offset” etc, and 
the information to be scheduled and tagged. 
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2.6 Survey Point, Project Base Point, Grid, Internal Origin, 
Levels and Work Planes 
2.6.1 Survey Point 
Survey Point is an absolute and true coordinate of a project surveyed by a land surveyor. 
Commonly, it is typically set at a point in the boundary line. The value should match exactly as the 
survey information. 
 

2.6.2 Project Base Point 
Project Base Point defines the origin of the project coordinate system initially. Location of point can 
be determined by the team as a reference point. It can be used to establish a reference for 
measuring distances and positioning objects in relation to the model and used to position the 
building on site. It refers to a point common to all stakeholders which is typically set at a point in 
the intersection of two grids or special feature location of the site boundary by the architects and 
designers. 
 

2.6.3 Internal Origin 
Internal Origin is a start-up point for the Revit internal coordinate system and it never moves. 
Model geometries are recommended to be placed within a 16 kilometer radius from the Internal 
Origin for stable and reliable model behaviour. 
 

2.6.4 Grid 
Grid is an annotation element that help to determine whether grids appear in each plan view that 
you create for a project. 
 

2.6.5 Level 
Level can act as a reference for level-based elements for story or reference plane within a building. 
In a section view or elevation view, it can add a level line in a model and create an associated plan 
view. 
 

2.6.6 Work plane 
Work plane defines a virtual 2-dimensional surface used as the origin for viewing or for sketching in 
the model. It can create on Architecture / Structure / System tab. 
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2.7 Link Model Reference Type 
When you underlay a model through link Revit model, reference type of the link shall be well-
defined according to the purpose. 
 Overlay - load the link in the host model only 
 Attachment - load the link as nested in the host model 
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2.8 Views and Sheets 
Views are oriented to specific coordinates such as plan, elevation, section, callout, 3D View and 
camera. Schedule, legend and drafting view are another way of viewing information in neither 2D 
nor 3D. A new view can be generated from the create panel on View tab of the ribbon. 
 

 
 
Sheets are used for documentation. Sheet can be created through sheet composition panel or in 
Project Browser as below: 
 

Sheet Composition panel on View tab

 
Create Sheet in Project Browser  

 
After the initial setup of the sheet, desired views could be dragged directly from the Project 
Browser to the workplace of the sheet. However, all the views (except schedule and legend) can 
only be inserted to the sheet once in the project. If the plans are needed to be appeared more than 
one sheet, you should duplicate the view for another sheet insertion. 
 

 
Or you can right-click a view name in Project browser and select one of the Duplicate View 
commends. 
 
 
After creating a model in Revit, you can print the sheets by creating viewport for collecting 
documents. A sheet set consists of many sheets. Layout, elevation, section, schematic, details, 
schedule, legend etc. can be included in the sheet set. 
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2.9 Tag, Symbols and Dimensions 
Tag is an annotation (label) to identify elements in a drawing. Tag is intelligent, bi-directional 
graphics that report information stored in an object’s properties. Once you have tagged an element 
and entered a value in the tag, the tagged element will retain that value until you remove it. 

 
 
The symbol is a graphic representation of an annotation or other object. 

 

 
Dimensions are used to convey the distance or angle between elements or part of elements. It is a 
bi-directional annotation that you can edit the distance directly within the dimension string to move 
elements a specific distance apart and updates automatically. There are permanent dimensions 
and temporary dimension can be used in the model. 

 
 
 

2.10 Different Parameters 
All contents in the model have parameters, which are simply the information or data about the 
objects/ items.  

 
Parameters that you create display in the Properties palette or Type Properties dialogue under the 
group you define and with the values you define. 
 
Project Parameters - specific to a single project file and cannot share with other projects. They are 
added to elements by assigning them to multiple categories of elements, sheets, or views. It can 
be used for sorting, scheduling, and filtering. 
 
Family Parameters – control variable values of the family, such as materials. It is specific to the 
family. 
 
Shared Parameters - can be used in multiple families or projects. The definition of a shared 
parameter is stored in a separate file (.txt). After assigning a shared parameter definition to a family 
or project, the corresponding shared parameters’ value can be tagged and scheduled in the 
project. 
 



 

16 

G
etting Start 

3 Getting Start 

This chapter covers how to configure and manage standards through the development and use of 
a project template. The template can be rich with information that goes beyond the out of box 
content that Revit provides. Thus, the template setting is established, content explains how the 
reuse of work will increase productivity and standardise with each project for different statutory 
submission. 
 

3.1 Open a new project in Revit 
Open Revit ➜ click “New” button ➜ click “Browse” in New Project browser to open template 
(CIC_Template_MEP.rte) ➜ click “OK” 
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3.2 Set Project Coordinates (Building Projects) 
For building projects, the coordinates shall be defined by the Architects. To make reference to 
the Architectural model, it shall be linked into the MEP project by “Internal Origin to Internal Origin”. 
 

 
 
Open a floor plan at project ground level as site plan in Revit ➜ click “Manage” in ribbon ➜ 
“Project Location” ➜ “Coordinates”➜ click “Acquire Coordinates” ➜ select Architectural Link Model 
 

 

 
 
The Project Base Point shall be updated accordingly. However, the elevation (mPD Level) of 
project ground floor shall be “Specify Coordinates at Point” manually. (For Revit 2020, this exercise 
is not required if your Revit has updated with 2020.2.4 Hotfix.) 
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In the same view, select the Survey Point, unclip the point. Move the Survey Point manually 
towards the targeted location which is stated in Architectural Link Model.  

 
 
To generate a good model of housing keeping, the user shall pin the Project Base Point and 
Survey Point after relocation. 
 
All the Internal Origin, Project Base Point and Survey Point shall be invisible for all the views, 
except the site plan, after linking all the project models. 
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3.3 Set Project Coordinates (Civil Projects) 
For civil projects, the coordinates might be defined by the Engineers. The setup shall regard to as 
survey plan. 
 
Open a floor plan at project ground level as site plan in Revit ➜ Insert survey plan (in .dng or .dwg 
format) into the view by clicking “Insert” ➜ “Link CAD.”  

 
 
Move the survey plan regarding the desired Project Base Point towards the Internal Origin (i.e. 
same as the initial Project Base Point (0,0,0). Pin the survey plan to avoid being moved 
accidentally. 
 

 
Click “Manage” in ribbon ➜ “Project Location” ➜ “Coordinates” ➜ click “Specify Coordinates at 
Point.” 
 

 

 
 
 
 
  

Targeted Project Base Point 
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Click the targeted Project Base Point on the site plan ➜ Define the coordinates of the Project Base 
Point, Elevation (mPD Level) of project ground floor and angle from Project North to True North. 
 

 
 
In the same view, select the Survey Point, unclip the point. Move the Survey Point 
manually towards the targeted location, which is stated in Architectural Link Model.  

 
 
To have good model housing keeping, the Project Base Point and Survey Point shall be pinned 
after relocation. 
 
All the Internal Origin, Project Base Point and Survey Point shall be set to invisible for all the views 
,except site plan, after linking all the project models. 
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3.4 Site Boundary 
Site boundary (Property Line in Revit) shall be prepared by Architects in Building Projects. MEP 
engineers should not model the site boundary separately. 
 
Thus, to show the Architectural site boundary from Linked Architectural 
Model, user shall turn on the visibility of Property Lines under the Site 
category in the Visibility/ Graphics Override panel.(Advanced control on a 
filter, workset and link view settings depend on the model management for 
each project.) 
 
 
 
 
 
 
 
The engineers may lead all the Civil Projects. Engineers then shall be responsible for preparing the 
site boundary in the MEP models. The site boundary could be determined by survey data or 
sketching according to a reference survey map. 
 
Click “Massing & Site” ➜ “Modify Site” ➜ “Property Line” to add property line. 
 

 

 
 
 
 

Create by entering distances and bearings 
 

 

Create by sketching 
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3.5 Create Grid and Level 
 
Grid and Level shall be prepared by Architects in Building Projects. To copy the grid and level from 
Architectural Link Model, “Copy/ Monitor” shall be used. 
 
Open site plan or appropriate plan where grid locates in the Architectural Link Model ➜ 
“Collaborate” ➜ “Copy/ Monitor” ➜ “Select Link” ➜ click Architectural Link Model 

 

 
 
Click “Copy” ➜ Select appropriate Grids ➜ click “Finish” 

 
 
Open an elevation view and repeat the above steps to copy the levels. 
 
By the “Copy” function, the location and information of the grid and level from the Architectural Link 
Model would be copied to the MEP model. The relationship between the link model and copied 
elements would be monitored. A warning will be popped up if there is a change of relationship, not 
limited to naming, location or deletion. However, it is a reminder to the users. The copied elements 
would not be automatically updated unless you declare in “Coordination Review”. 
 
Users may go to the site plan to create an extra grid for the MEP model or a civil project,. 
Click “Architecture” ➜ “Datum” ➜ “Grid” to create a grid in the model according to a specific 
design.  
 
To create extra level for MEP model or for civil project, you may go to the elevation view. 
Click “Architecture” ➜ “Datum” ➜ “Level” to create a level in the model according to a specific 
design.  

 

 
 
Remark: The naming of grids and levels should be unique. 
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3.6 Managing Project Browser 
 
More than one set of views and sheets might be prepared in the same model. To manage the 
views in Project Browser, “Browser Organisation” is crucial. 

 
 
In CIC sample project, the views are filtered and arranged as below: 
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The “View Group” and “View SubGroup” are the custom project parameters added to the model. 
 

  
 
They could be also prepared by Shared Parameter in order to apply to multiple projects. 
 
Each view’s information shall be input to the corresponding parameter through the “Properties” 
panel. 
 

 
 
A similar setting is applied for Sheet Arrangement as below: 
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4 Creating Model Objects 

4.1 Mechanical System: Pipework 
 
The following objects will be modelled for every service that involves Pipework (i:e Water Supply 
Services, Drainage Services, Fire Services, MVAC-Pipe etc.) : 
 
The Pipe, Flex Pipe, Piping System and Pipe Type are defined as System Families, while Pipe 
Fittings and Pipe Accessories are defined as Loadable Families in Revit. Most parameters and 
functions for the system family cannot be edited or modified by users, except the below settings. 
 
Before starting the plumbing project, Piping System and Pipe Type should be well established. 
 
 

4.1.1 Piping System 
 
Piping System indicates the function of the complete pipework. 
 
In the project browser, find the Piping System under the families category to create a piping 
system.  
 

 
 
Listed piping systems are default settings in Revit. Each system contains unique settings. An 
appropriate system should be duplicated and renamed according to the project needs. 
 
Reference Table for Piping System (System Classification): 
Sub-category Functional type (System) Functional type (short form) 
Domestic Cold Water Fresh Water Pipe PL FWP 
Domestic Hot Water Hot Water Pipe PL HWSP 
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Once the piping system is created, establish the unique setting for each pipes settings under type 
properties for the type of material, mechanical settings and rise/drop symbols setup accordingly. 
 

 
 
It is recommended to assign an abbreviation to the drawings to the “Abbreviation” parameter while 
a detailed description of the system should set to the “Description”. 
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4.1.2 Pipe Type 
 
The Pipe Type indicates the material and fitting arrangement of the pipe. Typical fitting types shall 
be set as routing preferences. Therefore, pipe fittings can be automatically generated when 
drawing pipework. 
 
In the project browser, find the Pipe Type under the families category.  

 
 
Select “Default” or appropriate Pipe Type ➜ click “Edit” under “Routing Preferences.” 
 

 
 
Set appropriate pipe material and pipe fitting family type in corresponding pipe size  
 

 
  



 

28 

C
reating M

odel O
bjects 

4.1.3 Modelling Pipe 
 
In Ribbon, click “System” ➜ click “Pipe” under “Plumbing & Piping.” 

 
 
Select the appropriate Pipe Type and System type in the properties panel. 

 
 
Under the ribbon panel, select pipe diameter and offset from the reference level. 

 

 
Specific the slope direction and value for the pipe. 

 
 
Define the starting point and endpoint of the pipe by clicking.  
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Adding insulation to pipe 
Select the specific pipe ➜ in the ribbon, click “Add insulation”. 

 
 
Define the Thickness and edit the Material as desired 
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4.1.4 Loadable Families for Pipework 
 
4 common Loadable Families that will be connected with Pipework are namely “Pipe Accessory”, 
“Sprinkler”, “Plumbing Fixture” and “Mechanical Equipment”. 
 
The best practice is to develop all Pipe Accessory, Sprinkler, Plumbing Fixture and Mechanical 
Equipment families nested with a 3D model family and an annotation family (symbol). 
 
To place the families, click desired category under “System”  

 

 
 
Select appropriate Family and Type in “Properties” panel (1) or click “Load Family” (2) to load a 
desired family into the current project ➜ define parameters 
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4.2 Mechanical System: Ductwork & Mechanical Equipment 
 

The following objects will be modelled for MVAC plan: 
 
 

4.2.1 Ducting System 
 In Revit, Duct, Ducting System, Duct Placeholder, Flex Duct and Duct Type is a System 

Families, while Duct Fittings, Air Terminals and Duct Accessories are Loadable Families. 
 Most of the parameters and functions for system family cannot be edited or modified by 

users, except by below settings. 
 Before starting the MVAC project, Ducting System and Duct Type should be well defined. 
 Ducting System indicates the function of the complete ductwork. 
 Duct Type indicates the shape and material of the duct. 

 

4.2.2  Creating Duct 
 
Creating Duct System 
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Creating Duct Type 

 
 
Adding insulation to duct 
Select the specific duct ➜ in the ribbon, click “Add insulation” 

 
 
Define the Thickness and edit the Material as desired 
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4.2.3 Setting up Duct Fittings 
 
Typical fitting types shall be set as routing preference. Therefore, duct fittings can be generated 
automatically while drawing ductwork. 
Assign the material for specific (material) duct fittings after the pipework has been modelled. 
 
To set or change the routing preference. 
Select the duct ➜ ensure the desired “Pipe Type” ➜ navigate to “Routing Preferences” and click 
“Edit” 

 
 
Set from the default families (1) or load a unique fittings as desired (2) 
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4.2.4 Loadable Families for Ductwork 
 
In Revit, there are 3 Main Loadable Families that will be used under Ductwork design. They are 
Duct Accessory, Air Terminals and Mechanical Equipment. The best practice is to develop all Duct 
Accessory and Mechanical Equipment families nested with a 3D model family and an annotation 
family (symbol). 

 
 
Duct Accessory 
 All appropriate duct accessory (connectors) shall be modelled in family. 

 
Air Terminals 
 Select a suitable hosting type for the components as it cannot be exchanged to other 

hosting types. 
 Air Terminals could be “free stand” family modelled in MEP model. 
 Air Terminals could be also hosted on ceiling shall be modelled in ARC Ceiling model file 

and collaborated with Architects. 
 
Mechanical Equipment 
 
 For large equipment, a service space/ maintenance space shall be modelled as LOD-I 300. 
 A generic service space family with service space/ maintenance space sub-category is 

suggested to nested with large equipment family. Dimension of the generic service space 
family shall be controlled by shared parameters. This approach can benefit and facilitate 
the visibility control for the service space across different categories. 
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4.3 Electrical System: Cable Tray and Trunking 
 
Cable trays and Conduits are both used for providing protection in an environment where either 
large or small quantities of power control cables are at work. Besides providing mechanical 
protection, these cables are also designed to facilitate a perfect routing path for power or control 
cables 
In Revit, both are in the same category which is “Electrical” 

 
 
 

4.3.1 Creating Cable Tray 
 
Under “Electrical” ➜ click “Cable Tray” ➜ Set suitable Cable Tray type ➜ Set dimensions and 
offset ➜ Define Service Type 
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Best practice is to define all these setting first 

   

 
 

4.3.2 Setting up Cable Tray Fittings 
 
 Typical fitting types shall be set as routing preference. Therefore, cable tray fittings can be 

generated automatically while drawing cable tray work. 
 It is NOT suggested to create a fitting family unless there is insufficient fitting design in 

Revit family library. 
 Please follow the below procedure to modify the fittings provided from Revit Library for 

Hong Kong Practices for Design Stage only. 
 
To set or change the routing preference. 
Select the cable tray ➜ set to the desired “Cable Tray” ➜ navigate to “Fittings” and change as 
desired ➜ set the “Bend Radius Multiplier” 

  

Reference Level 
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4.3.3  Creating Trunking 
 
 There is no direct tool to develop Trunking in Revit. 
 Method 1: Model by duct with different system names and the setting is used to imitate 

trunking in Revit environment. Details refer to section 4.2 Mechanical System: Ductwork & 
Mechanical Equipment. 

 Method 2: To maintain the electrical properties of the “trunking” element, it is advised to 
prepare the “trunking” by using a cable tray with a different type name and setting. The 
geometry (size) of the trunking could serve 3D coordination. However, it could not reflect 
the realistic 3D presentation. 

 
Detail 
Level 

Visibility Setting 3D Model 

Medium 

 
 
Uncheck Centre line 

 

 
4.3.4 Loadable Families for Electrical System 
 
In Revit, there are 3 Main Loadable Families for Electrical Systems. They are Electrical Equipment, 
Device and Lighting Fixture. The best practice is to develop all 3 Families nested with a 3D model 
family and an annotation family (symbol). 

 
 
Each of the Families is uniquely set with specific Service Type either Low-Voltage SSO, Extra-Low 
Voltage Devices or even equipment. 
 
To use these features, just navigate to desired selection under Electrical Ribbon. 
These Main Families is completed with 8 Sub Families which is under the “Device” ribbon. 
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4.4  BIM Object for MEP 
4.4.1  Maintenance/Service Space 
Maintenance space, also known as clearance area, is a designated area for machinery and other 
objects that may require maintenance or safety measures. There is no other object that can be put 
in the maintenance space. Keep in mind that the maintenance area isn't usually included in the 
drawing production. Please follow the steps outlined below to create a maintenance area : 
 
 The maintenance space should create as a separate family and nested into equipment 

family. 
 The maintenance space should use generic model and set as a “Shared” family and 

determine sub-category such as “Maintenance Space”. This method allows user to control 
all maintenance space visibility by sub-category under generic model without limitation of 
different equipment family categories. Also, use sub-category to control the maintenance 
space edge line displaying on plan view and elevation view. 

 The maintenance space should create by parametric modelling to allow user to change its 
size in equipment family. 

 The maintenance space should be transparent in the 3D view, normally set as 80% in 
material setting. Also, the transparent setting is not appearing in 2D view so the space 
should be invisible in 2D view. Use symbolic line to represent the edge of the maintenance 
space in 2D view. 

 The maintenance space should provide a parameter to control its visibility. 
 
Example for Mechanical Equipment Maintenance/Service space: 
Generic Service Space family 

 

Large equipment family nested with Generic Service Space family 
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Example for Electrical Equipment Maintenance/Service space: 
 
Generic Service Space family 

 

Large equipment family nested with Generic Service Space family 
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4.4.2  Issue of Plan View Cut Plane 
Usually, a floor plan shows all the elements, which are cut by the cut plane (around 1200mm to 
1500mm from level), in the associated level. Some elements located at a high position such as exit 
sign, hose reel and alarm bell etc. may not be visible since they are above the cut plane due to 
software’s interpretation. 
 
Therefore, a visibility quality checking should be carried out during drawing preparation to ensure 
targeted objects are presented on the plan clearly under a right setting. 
 
 If “specialty equipment” or “generic model” category is placed above the cut plane but 

below the top clip plane which defined in view range setting, it will not display on the plan 
view unless its category is window, casework or generic model. 

 However, in some case, user will expect to show the family’s symbol on the plan view 
without modify the cut plane setting. 

 Create one model line on the reference level and set its “Visible” property to false. 
 
Example: 
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4.4.3 Orientation-independent Symbols 
 As 2D Symbol is nested with 3D model, it rotates corresponding to the 3D model in project. 
 Under the situation that all the symbols on plan are arranged in the same orientation, the 

model is required to nested more than 1 symbol or using parameters to control the rotation 
of the symbol. 
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4.4.4 Creating a Shared Parameter in Mechanical Equipment Family 
 
Usually, there is only a “Default Elevation” that was created when first time creating a mechanical 
family. Hence it is important to create and categorize each element with proper functional 
parameters so it can be used in generating a schedule. 
 

 
 

Go to “Create” tab ➜ Properties Category ➜ Select the “Family Types” . A “Family Types” 
dialogue box will prompted. Under the same dialogue box, click on “New Parameter” symbol  to 
create a new parameter.  
 

 
 
A dialogue box of “Parameter Properties” will be prompted. Click on “Shared Parameter” ➜ 
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“Select”. 
 

 
 
Under the “Shared Properties box ➜ click on “Edit”. 
 

 
 
Go to “Create” for your own “Shared Parameter File” with an appropriate naming and location or 
can click on “browse” to find the existing “txt File” saved ➜ click “New” under “Groups” section to 
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create a new parameter group ➜ click “New” under “Parameters” to create a new parameter 
element. 
 

 
 
Fill all the information needed in the “Parameter Properties” dialogue box. Then click “Ok”. 
 

 
 
Using shared parameters could facilitate the setup for schedule. Refer to 5.1 Select Fields for 
Schedule. 
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5 Preparing Schedules 

 
In the project ribbon, go to “View” ➜ “Schedule” ➜ “Schedule/Quantities” 
 

 
 
Once the “New Schedule” window opens, select the “Mechanical Equipment” under the “Category” 
column. Set the unique name to “FCU Equipment Schedule”. Make sure “Schedule Building 
Components” and Phase “New Construction” is selected. After that, click “Ok”. 
 

 
 
A “Schedule Properties” will prompt. Within the window, there are five (5) different tabs we can use 
to organise the settings for the schedule. There are “Fields”, “Filter”, “Sorting/Grouping”, 
“Formatting” and “Appearance”. Each of the tabs will be introduced in the coming sections. 
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5.1 Select Fields for Schedule 
 
Under the “Fields” tab, then go to the “Available Fields” drop-down and select the “Mechanical 
Equipment”. Later, pick any “Appropriate Parameters” under the “Available Fields” to specify the 
information to be included on the schedule. Use the icon“ ” to move the parameter from the left 
column to the right column. Otherwise, “double click” in the “Available Fields” column to add on into 
the “Schedule Field” column. 
 
As mentioned in Section 2.5 Parameters, there are two types of parameters for custom family 
elements; the Built-in-Parameter and the Shared Parameter. The Built-in Parameter is the element 
or information that already existed in the project, hence no changes can be made. The Shared 
Parameter is an additional element that has been added into the family or project for easy access 
to extract the stored information to be used in tagging and scheduling purposes and it can be 
updated at anytime. 
 

 
 

5.2 Data Filter in Schedule 
 
Go to the second tab, “Filter”. Use filter by “Type Comments” ➜ “contains” ➜ “FCU” (this depends 
on what has been written in your type comments section). 
 
This process is needed because all mechanical equipment has been selected using the “Family 
Parameter” in the “Fields” tab earlier. Therefore, only mechanical equipment with “FCU” written in 
the “Type Comments” only selected in generating this schedule. 
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5.3 Sort and Group in a Schedule 
 
Go to the third tab, “Sorting / Grouping”. Select sort by “Level” ➜ then by “Type Comments” ➜ 
ascending order are selected for both. By default, “Itemize Every Instance” is selected but during 
this exercise, this is turned off.  
 
In this exercise, two types of different FCUs have been used. Hence, the “Type Comments” 
parameter has been used to show these two types of equipment in the schedule.  
 
Ascending order has been selected to organize the level of that particular mechanical equipment 
located. Therefore, the first row of the schedule will start from GF until RF.  
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5.4 Formatting in a Schedule 
 
Go to the fourth tab “Formatting”. Go to each parameter under “Fields” category to specify 
formatting options to change name under “Heading” and “Alignment” change the header alignment.  
 

 
 

5.5 Appearance in a Schedule 
Go to the fifth tab, “Appearance” and then untick the “Blank row before data” under the graphic 
setting. Next, change the font type for each “Title Text”, “Header Text” and “Body Text’ under the 
text setting ➜, then click “Ok”. 
 

 
 
After that, find the row that has indicated the column starting from “A”. Drag from “A” to “J” to select 
all the columns and rows. Select all the schedules ➜ to modify Schedule / Quantities tab ➜ 
appearance ➜ align vertical ➜ select “Middle” context option. 
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The width of column size shall be adjusted in the sheet view after dragging the schedule into a 
created sheet.  
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6 Standardising View Setting 

6.1 View Templates 
“View Templates” are used to manage the view setting and control for multiple views. This could 
enhance the efficiency of the presentation setup for different submissions. It is suggested to have 
at least 1 set for working purpose and 1 set for drawing submission purposes. The standardised 
view properties include but are not limited to view scale, detail level, model display setting. The 
“View Template” could be applied to all plan view, section views, elevations, detail views and even 
3D views. 
 

6.1.1 Create View Template 
There are two (2) methods to create the view template. 
 
6.1.1.1 Create Template from Current View 
Create a view template from the view that is defined with good and appropriate presentation 
setting. 
 
On the “View” tab ➜ “Graphics” panel ➜ “View Templates” ➜ “Create Template from Current 
View”. 
 

 
 
Name the view template 
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6.1.1.2 Duplicate existing View Template 
 
Create a view template by duplicating the existing view template that has similar presentation 
setting. 
 
On the “View” tab ➜ “Graphics” panel ➜ “View Templates” ➜ “Manage View Templates”. 
 

  
 
Select the existing view template that has similar presentation setting ➜ “Duplicate”. 
 

 
 
Name the view template 
View Template Naming refer to Section 6.1.1.1 Create Template from Current View. 
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Modify the new view template settings according to the target submission presentation. 
 
It is suggested to standardise the view template name according to the table below: 
 

<Purpose>_ <Approval 
Authority>_ 

<Submission 
Name/ Remark> _ 

(if applicable) 

< Scale>_ < Type>_ <Remark> 
(optional) 

S_ FSD_ Dangerous Good_ 50_ Plan  
S_ EMSD_ BEEO_ 100_ Plan_ Water Side 
S_ EMSD_ L&S_Escalator_ 50_ Section  
W_  EL_ 100_ Plan_ Staff_Name 

 
Purpose (Abbreviation) Definition 

S Statutory Drawing 
W Working Drawing 

 

6.1.2 Apply View Template 
 
There are two (2) methods to apply view template. 
 
6.1.2.1 Apply Template Properties to Current View 
 
This method is to “borrow” the view properties from the existing view template after application. 
However, if there is any change in the view template, your targeted view will not be updated 
automatically. Otherwise, you shall refer to Section 6.1.2.2 Assign Template Properties for more 
details. 
 
Open the target view ➜ on the “View” tab ➜ “Graphics” panel ➜ “View Templates” ➜ “Apply 
Template Properties to Current View”. 
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Select target view template and view properties ➜ “Apply Properties”. 

 
6.1.2.2 Assign Template Properties 
 
This method could “lock” the view template to target views. Once there is a change in the 
corresponding view template’ view property, all the assigned views will be updated automatically. 
 
Select the target view(s) in Project Browser ➜ click “None” under “View Template” in “Properties” 
palettes. 
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Choose appropriate view template ➜ OK. 
 

 
 
The view template would be then be assigned to the target views. 
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All the assignment of view templates could be reviewed through View List under Schedules on the 
View tab. 

 

 
 
Operation of schedule refer to Section 5 Preparing Schedules. 
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6.2  Plan Views 
 
Discipline for each view should be well defined. The direction of view and graphics setting would 
be different between Architectural, Structural, MEP and Coordination. 

 
 
For MEP drawings, “Floor Plan” and “Ceiling Plan” are the usual plans. Both are controlled by 
“View Range”. 

 
 
The below figures indicate the direction of the view and common setting for different plans under 
the MEP discipline.  
 
In the MEP floor plan, system families (such as duct, pipe, cable tray etc.) would be shown with the 
view direction order from top to bottom. Therefore, the “Top” of view range is “Level Above”. The 
“Cut Plane” is usually set at 1200mm or 1500mm above the Associated Level (Structural Level). 
Any custom families’ geometries are cut by “Cut Plane” or located within the “Cut Plane” and 
“Bottom” zone, including the windows and doors, they would be shown on the floor plan. The 
“Bottom” is the Associated Level without offset. These settings could ensure adequate model 
elements to be shown in the view. The setting may be adjusted slightly according to different 
project and site conditions. 
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In the MEP ceiling plan, the “Top” of view range is “Level Above”, while the “Cut Plane” is usually 
set at 2000mm above the Associated Level (Structural Level), i.e. around the ceiling level. Usually, 
the “View Depth” is zero. All the fixtures, sprinklers, detectors etc., are under the ceiling or within 
the MEP zone (i.e. between “Top” and “Cut Plane”). The setting may be adjusted slightly according 
to different project and site conditions. 
 

 
 
Crop Region 
Crop Region can control the boundaries for the view. Datum elements such as levels and grids can 
adjust automatically according to the crop boundary. The Crop Region also cab be used to resize 
the viewport on the sheet. 
Annotation Crop Region 
Annotation Crop Region can control the annotation boundaries in the view. By default, it only 
displays independent views and callout views, but not in the primary view. It is advised to activate 
the annotation crop region and adjust it until the annotations are well displayed. 
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6.3 Section Views 
 
Section views display as section representations in intersecting views. Provide views of specific 
parts of your model. The crop region and view range must intersect for a section tag to be visible. 
 
Click View tab ➜ Under “Create” panel ➜ Click at the “  (Section).” ➜ Drag the Section as 
desired on plan 

 
 
It is advised to prepare Section Type according to different drawing submissions and working 
sections. This could facilitate the visibility control on Section Filter for the succeeding drawing 
preparation. 
 

 
 
Adjust the Section depth as preferred. It is not recommended to have a deep section. 
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6.4 Callout Views 
Callout View shows a blow-up view or an enlarged version of part of the parent view and provides 
more information about that the building model. You can add a detail callout or a view callout to a 
plan, section, detail, or elevation view. 
 
It is recommended to prepare the blow-up view or an enlarged version using Callout View instead 
of creating a new floor plan view separately. The relationship between the Callout and the parent 
views would be established in Revit. The reference drawing number of the Callout could be 
generated automatically in the parent view (master floor plan). 
 
When you draw the callout bubble in a view, Revit creates a callout view. 
 
Click “View” tab ➜ Under “Create” panel ➜ Click at the ”  (Callout) “.➜ Drag the “Callout” cloud 
as desired on plan or section 

 
 
Adjust the area for the callout view as preferred. 
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6.5 3D Views 
 
3D Views are helpful for MEP coordination. It is efficient for clash detecting either between other 
Disciplines or within MEP services itself. 
 
A quick method to prepare a 3D view for target elements 
 
Select the target element ➜ Go to “Modify” tab ➜ click “Selection Box”. 
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7 Model Segregation 

7.1 Discipline Model 
 
The Engineers shall prepare the model by disciplines as the sample below. The overall hierarchy 
of the project models shall be introduced clearly in the BIM Execution Plan (BEP). If the file size 
has exceeded the limit listed in the BEP, the discipline models shall then be further segregated by 
zone or services zone. 
 

 
 
Above model segregation is not limited to Revit, it also applies to the discipline models which are 
prepared by other software. Reference models could also be linked through Industry Foundation 
Classes (IFC) format. 
 
Details refer to 
 
 CIC BIM Standards – General Section 5.8.2 Collaboration 
 CIC BIM Standards – General Section 7 openBIM. 
 Revit IFC Manual – Detailed instructions for handling IFC files (Autodesk Inc., 2018) 
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7.2 Worksets 
 
Worksharing could enable multiple users to edit the Revit Project models at the same time. 
Workset serves as permission contain originally. In fact, workset can serve as a purpose container 
efficiently since the elements would not be disconnected and the control on visibility is easy. 
 
Recommend worksets: 
 
Workset Elements to be included 
General Modelling All elements except those listed in the below worksets. 

This is renamed from “Workset 1” which is the default workset in Revit. 
Shared Grids and Levels Grids and Levels 
Revit Link All Linked Revit 
CAD Link All Linked CAD 
Builders Work Plinths, Openings, Supporting etc. 
Hidden To be hidden from the modelling due to Revit modelling limitation 
(By Discipline) * 

* If the project is relatively small, it might be possible and efficient to prepare all the discipline 
elements within one Revit Project file. It is suggested to assign the elements using unique 
discipline worksets. This arrangement shall seek prior approval by the Appointing Party (Client) 
and BIM Manager. 
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8 Collaboration with Other Disciplines 

8.1 A/S/M Plinth 
 
Refer to CIC MEP BIM Guide Section 8.9.1 A/S/M Plinth for general workflow. 
 
Plinth elements shall be modelled under “Builders Work” workset or “CBWD” workset. The user 
could control the visibility of elements easily by controlling the corresponding workset. 
 
It is recommended that the Engineers model the simple Plinth elements by a cuboid parametric 
family. 

 
It is recommended that the Engineers prepare a separate family (as sample below) for equipment 
such as chiller and pump. 
 

 
The last priority options to model the Plinth are using “Floor”, which with the Type Name Descriptor 
as “_Plinth”, and “In-Place model”, which only for irregular form and with Type Name as 
“<Level>_<Room/ Location>_Plinth”. 
 
Methodologies adopted shall be informed to the Architects, the Structural Engineers and the 
Quantity Surveyors. 
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8.2 A/C/S/M Manhole 
 
Refer to CIC MEP BIM Guide Section 8.9.2 A/C/S/M Manhole for general workflow. 
It involves cross-discipline collaboration on the manhole design. 
 
Architects shall be modelled the Manhole elements in ARC model for initial advisory purpose for 
MEP Engineers and Structural Engineers. MEP Engineer shall refine the design and model a 
detailed manhole under the drainage services of the MEP model. 
 
The Civil Engineer shall be in charge of the whole manhole design, location arrangement, 
structural analysis and manhole schedule preparation for the civil projects. The manholes shall be 
modelled in the civil model. The Engineers shall place the appropriate model families in the civil 
model according to the architectural layout. 
 
However, for the design stage, it is not recommended to have over-modelled in the manhole 
family. For the manhole family, it shall at least equip the following information: 
 Usage (LOD-I), 
 Manhole Type (LOD-I), 
 Overall Manhole Type Geometry (LOD-G), and 
 Inner size (LOD-G) etc. 

 
Further details on manhole interior design should be presented by 2D detail drawings or a separate 
detail modelled family, which shall not be adopted in the project modelling. Otherwise, the over-
modelled family may increase the loading time, file size and affect the model navigation. 
 
The Revit family’s connector is not adaptive as same as the reality. They would not relocate 
automatically to the inlet pipe’s and the outlet pipe’s positions nor adjust the angle to fit with 
connecting pipe’s slope. 
 
In practice, the drainage pipes connecting to the manhole or Gully should be modelled with the 
correct slope and size in order to spot out the invert levels. However, there is no “real” connection 
between the manhole and pipes. The information of pipes connecting to the manhole shall be input 
manually. 
Not practical to control all the connectors for 
inlet and outlet pipes 

Practical Situation 
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9 Preparing Drawing Production 

9.1 View Preparation 
 

9.1.1 Duplicating views 
 
Since the view can be only inserted into the sheet once in Revit, for drawing production, the users 
may duplicate the view for further editing. 
 
Select the desired plan ➜ right click ➜ click “Duplicate View” ➜ “Duplicate” ➜ re-naming the sheet 
to “Unique Name” 

 
 
 

9.1.2 Background Layout Setup 
The Architectural, Structural and other MEP disciplines model within the BIM model should be 
referenced. Details refer to 7.1 Discipline Model. 
 
However, there may be different design authoring tools used for each discipline in a project. Below 
is the recommended workflow to handle the layout setup. 
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9.1.2.1 Revit Models Approach 
 
Layout Plan / Part Plan 
 

 
 
 

  
  

 
 

 
 
 

 
 
 

 
 
 
 
 
 

 
 
 
 
 

 
 
 

 
 

 
Assuming Architectural Drawings and Structural 
Drawings are prepared by Revit and liable to 
inline with the statutory drawings. Therefore, it is 
recommended that the layout of ARC and STR in 
the MEP model are prepared by “By Linked View” 
and their specific plan views. 
This method can save time on background layout 
presentation setup. Furthermore, the “view range” 
and elements’ visibility of the background layout 
shall be relied architects’ and structural engineers’ 
needs. Once ARC and STR drawing models 
change, the background layout for MEP shall 
update together. 
 

Underlay Layout 
of ARC model  

Underlay Layout 
of STR model  

Host MEP model 
Layout  

Layout Drawing 
Presentation 
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Section/ Elevation 
The true size of models shall be reflected in the section and elevation. Therefore, section and 
elevation outline the shape of the elements at a specific angle or direction. Revit Links are 
recommended to set as “By Host View” to control the presentation better. 
 

 
 
Meanwhile, the control on visibility, graphic and filter for different categories and elements can be 
applied throughout the host model and all the Revit Links. 

   
 
 
  



 

68 

Preparing D
raw

ing Production 

9.1.2.2 openBIM Approach 
 
Due to the limitation of interoperability between different BIM design authoring software, Revit may 
not extract the native data and object through the method mentioned in section 9.1.2.1 Revit 
Models Approach. If so, it is recommended to link the reference model through Industry Foundation 
Classes (IFC) format. 
 
Layout Plan / Part Plan 
 

 
 
 

  
  

 
 

 
 
 

 
 
 

 
 
 
 
 
 

 
 
 
 
 

 
 
 
 
Since IFC model could not retrieve the drawing setup prepared in the design authoring tools, it is 
the last resort and only way to underlay the reference “drawings” which are the approved statutory 
drawings from Architects or Structural Engineers through linked dwg, pdf or dwf formats. 
 
However, this is not implied that the coordination and collaboration work revert back to “2D CAD 
coordination”. The 3D BIM IFC models should be used as geometry coordination and BIM 
information review. The recommended underlay of drawings above is only the workaround method 
for drawing production purpose only. There may be enhanced methods upon the development of 
IFC exporter and reader upgrade. 
  

Underlay Layout 
of ARC drawing  

Underlay Layout 
of STR drawing  

Host MEP model 
Layout  

Layout Drawing 
Presentation 
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Section/ Elevation 
The true size of models shall be reflected in the section and elevation. The IFC model should be 
used as background layout reference. However, the geometry in IFC may be triangulated. Extra 
edge of topology may be shown as the image below.  
 

 
 
Users shall have manually touch-up on the presentation through “linework” under 
“Modify” ribbon.  
 
Then select “Invisible lines” type to override the triangulated edge. 
 
Override the edge Presentation of IFC after touch-up 
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9.1.3 Add Dimensions 
 
Create the appropriate dimension under Dimension in Ribbon. 

 

 

 
 

9.1.4 Add Annotation Symbols 
 
Click “Annotation” in ribbon ➜ click “Symbol” to place annotation 
symbols. 
 
 
 
 
Select the specific type of symbol from “Properties”. 
 
 
 
 
 
 
Place it to desired location. 
 

 
 
These annotation symbols are placed manually to enhance the presentation and elaboration of the 
drawing.  
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9.2 Tags 
9.2.1 Add Tags 
 
Click “Annotation” in ribbon ➜ click “Tag by Category”. 
 

 
 
Click “Tags..” in Option bar. 

 

 
Assign the required tag family and type to each category and click “OK”. 

 

Click the desired object to tag. 
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9.2.2 Add Tags for Riser 
 
The user will assign the drawing information production to the pipe once all the pipeworks have 
been modelled. The riser, the vertical pipe crossing all levels, may have different versions of 
information for drawing production. Therefore, the user shall assign appropriate information to the 
parameters below carefully: 

 
Assign appropriate information to corresponding parameters on the same elements. 
 
 

9.2.3 Add Tag for Direction of Flow 
 
For a Pipe with Slope or Gradient, there are two ways to annotate them with “Tag” function as 
follow: 
 
9.2.3.1 Automatic Slope Tag 
 
Tag with “Spot Slope” tools 
Navigate to the “Annotate” tab ➜ Click “Spot Slope” ➜ Select the desire pipe to tag 
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Go to Property panel and edit the settings as preferred. 

 
 
It is advise to set the “Offset from Reference” to 0 and “Prefer” to Centre of core. 

 

 
 
 
 
 



 

74 

Preparing D
raw

ing Production 

9.2.3.2 Manual Direction Tag 
 
Tag with “Tagging” tools 
 
Navigate to the “Annotate” tab ➜ Click the “Tag by Category” ➜ Select the desired pipe 

 
 
Go to Property panel, select the tag type as shown below and uncheck the “Leader Line” box. 

 
 
Manually drag the tag to the centre of the pipe as shown below: 
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9.3 Creating Drafting View 
Despite creating 3D objects, 2D information can also be drafted in the drafting view when 
appropriate. For example, general notes and typical details. 
Click “Drafting View” under Create in View ➜ Re-naming the drafting view to “GENERAL NOTES” 
or by your own for easy reference. 

 
 

9.3.1 Text Note 
 
Insert text using the annotation tool. 

 
 
In the properties panel, choose the specific type of text. 
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9.3.2 Typical Details 
 
Create detail line / region. 

 

 

 
Create lines and choose different Line Style. 

 

Drafting the region by drawing tools. 

 

 
 
Examples of Detail Installation: 
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9.4 Creating Legend 
 
Click the “View” in ribbon ➜ click “Legends” to create a new legend view. 

 
 
Use the Annotation tool such as text, filled region and symbols to create the 
components in legends. 

 

 
 
Example of Legends created 
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9.5 Revision Cloud 
 
Revision Clouds is used to indicate design areas that have changed in a project. Use revision 
cloud annotations to mark drawing sections that have been revised. In project views, draw revision 
clouds to indicate areas of the design that changed. 
 
Open the desired view ➜ Navigate to the “Annotate” tab ➜ Under Detail panel ➜   (Revision 
Cloud) ” 

 
 
Revit enters sketch mode ➜ Drag/draw as desired 

 
Note : Best practice is to draw all “Cloud” with same revision together, this is to accurately label the 
Revision number. 
 
To set the Revision number or series 
Navigate to “View” tab ➜ Click “Revisions” 

 
 
Set the Revision details as preferred 
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9.6 Create Schematic Diagram 
 
The schematic diagram is drafted in the drafting view when appropriate. Details refer 
to 9.3 Creating Drafting View. It is advised to insert the schematic diagram (drafting view) 
into the sheet and confirm the scale before sketching. 
 

9.6.1 Add detail item for equipment 
 
Click “Annotation” in ribbon ➜ click “Component” in “Detail” to place detail item. 

 
 

9.6.2 Add lines 
 
Click “Annotation” in ribbon ➜ click “Detail Line” ➜ In “Properties”, select appropriate line type ➜ 
sketch the drawing. 
 
Example of Schematic Drawing  
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9.7 Creating Sheet 
 

9.7.1 Title Block 
 
 Title block family is available in central resource folder. 
 Title block family may be edited to suit project’s requirement. 
 The modified title block family is to be saved under project resources folder. 

 
Shared Parameter in title blocks: 
 
Parameter Function Display Name Parameter Type 
Project Name Project Type parameter 
Drawing Title Drawing Title Instance parameter 
Drawing Number Drawing No. Instance parameter 
Scale Scale Instance parameter 
Revision / Description / Date / Issued By Revision / Description / Date / By Instance parameter 

Drawn By / Checked By / Authorised By Drawn / Checked / Authorised Instance parameter 

 

 
  



 

81 

Preparing D
raw

ing Production 

9.7.2 Sheet List 
 
Users can create a tabular view of sheets in a project. From “View” tab in ribbon ➜ click 
“Schedule” ➜ click “Sheet List”. 
In the field tab of the sheet list, add the field name sheet number, sheet name, sheet issue date 
and sheet revision to the list of scheduled fields. 
To begin adding sheets to the sheet list, go to the row panel in ribbon ➜ click “Insert” ➜ click “Data 
Rows”. The users can continue populating the schedule in this way. 
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9.7.3 Guide Grid 
 
In Revit, the viewport of views placing on sheet cannot be assigned by coordinates as in CAD. 
However, Guide Grid can help in referencing sheets for an organized presentation. Plans views of 
different floors can be placed at the same spot across different sheets. 
 
Open Sheet View ➜ Navigate to “View” tab ➜ Under Sheet Composition ribbon ➜ Find “Guide 
Grid” 

 
 
Click the “Guide Grid” ➜ Select either ”Existing” or “Create New” 
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9.7.4 View Control 
 
9.7.4.1 Scale 
All model files are modelled at the 1:1 Scale. The Scale command in Revit mainly affects the 
scaling on annotations in a drawing. 
 
9.7.4.2 Detail Level 
To achieve the traditional presentation, the detail level setting for MEP elements shall be well 
defined. The below table lists the presentation for the common Revit MEP routing elements. 
 Coarse 

Level 
Medium Level Fine Level 

Duct Single Line Double Line Double Line 
Pipe Single Line Single Line Double Line 
Cable 
Tray 

Single Line Double Line 
(*Trunking 
presentation in 3D 
View) 

Double Line 
(*Cable tray presentation in 3D View) 

 

  
 
It is recommended to set Medium Level for standard layout plans to show all pipes in a single line 
and ducts in a double line. 
 
It is recommended to set Fine Level for plant room layout plan, callout (blow-up) view, sections 
and 3D views. 
 
9.7.4.3 Visual Styles 
 
Visual Style is the setting for graphic styles. The Hidden line style is commonly used to show 
the filled colour of components and lines for drawing production. Shaded Visual Style may be 
applied during coordination for easy understanding of the model arrangement. 
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9.7.4.4 View Filter 
 
View Filters based on a set of selected elements or based on categories and parameter 
values. Apply these filters to views to change the visibility or graphic display of elements. 
 
Setting up Rule-based filters to identify elements using parameter values for selected 
categories 
 
Hit “VV” ➜ Navigate to “Filter” tab ➜ Click “Add” button ➜ Select “Edit/New” to create a filter 

 
 

 
 
  

https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/2019/ENU/Revit-DocumentPresent/files/GUID-B451C74B-9214-4974-9A49-2B46A9F6D822-htm.html
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9.7.4.5 Visibility Overrides 
 
View-specific visibility and graphic display such as colouring, patterns, and line style etc. can be 
assigned using Visibility Overrides according to Model Categories, Annotation Categories, Filters, 
Worksets and Revit Links. In Revit, Filters have the highest priority in Visibility Override. 
 
Special arrangements for specific categories in detail level are suggested to be set in Visibility 
Overrides for drawing production purpose. It is recommended to create a view template with the 
setting shown below and apply it to all plan drawing productions. However, it shall be in Fine level 
for section and 3D in order to have the spatial dimension. Filter lists under Model Categories can 
be used to filter categories by discipline. 
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9.8 Types of Sheets Presentation 
 

9.8.1 Combined Information Sheets 
 
A Combined Information Sheet will consist of different Views, Schedules, Legends and 
Abbreviation composed in a single sheet.  
 
Example types of combined information sheet 
General notes, legends, abbreviation and drawing list 
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9.8.2 Schematic Drawing Sheets 
 
Schematic Drawing Sheets is used to present specifically all the schematic design drawing.  
 
Example types of the schematic drawing sheet 
 MVAC Schematic 
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9.8.3 Floor Plan/Layout Sheets 
 
Floor plan or Layout Sheets is sheets to present specifically all the Floor Plans with detailed 
annotations.  
 
Example types of floor plan/layout sheet 
 MVAC layout plan at level GF, L01, L02, L03 
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9.8.4 Schedule Sheets 
 
Schedule Sheets is sheets to present specifically all the schedule and detailed information. 
 
Example types of floor schedule sheet 
 FCU Equipment Schedule Sheet 
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9.8.5 Detail Drawing/Installation Sheets 
 
Detail Drawing/Installation Sheets is sheets to present specifically all the details drawing or the 
installation methodology. 
 
Example types of detail drawing/installation sheet 
 MVAC Installation details 
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9.9 Preparation for Publication 
 
Prior to the transmittal of the model, the file contents and structure need to be agreed. Drawing 
sheets from Revit shall be published to DWF (preferred) or stay in raw format (*.rvt), where they 
can be checked, approved, issued and archived. 
 
Printing 
Exporting all the sheets in PDF A1 or A0 paper size in PDF is recommended to ensure the sheets 
are printed in correct scale and resolution. The user may then print the corresponding PDF files in 
the required paper size. 
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10 Statutory Submission Sample 

Details refer to Appendix A - Software 1 Sample Drawings. 

10.1 Application for the Water Supply 
General Notes, Legends, Abbreviation and Drawing List 

 
Schematic Drawing 
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Plumbing Layout Plan at Level GF, L01, L02, L03 

 
 
Plumbing Layout Plan at Level L04-L15, RF, URF, TRF 
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Plumbing Pump Services at L01 

 
 
Arrangement Of Water Meter Cabinet at Level GF & RF 
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Underground Water Supply Layout At Level GF 
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10.2 Application for Drainage Services Department 
 
Drainage Connection Layout At Level L00 
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10.3 Application for Fire Services Department 
General Notes, Legends, Abbreviation and Drawing List 

 
 
F.S. Sprinkler Schematic 
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F.S. Layout Plan at Level GF, L01, L02, L03 

 
 
F.S. Layout Plan at Level L04-L15, RF, URF, TRF 
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F.S. Roof Sprinkler Pump Room at Level RF 

 
 
F.S. Dangerous Good Store Layout at Level GF 
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F.S. Static Smoke Extraction Plan 

 
 
F.S. Static Smoke Extraction Section 
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10.4 Application for Electrical and Mechanical Services 
Department 
General Notes, Legends, Abbreviation and Drawing List 

 
 
MVAC Schematic 
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MVAC Layout Plan at Level GF, L01, L02, L03 

 
 
MVAC Layout Plan at L04-L15, RF, URF, TRF 
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MVAC Plan, Detail & Section (I) 

 
 
MVAC Plan, Detail & Section (II) 
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Installation Details (I) 

 
 
Installation Details (II) 
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Installation Details (III) 

 
 
General Notes, Legends, Abbreviation and Drawing List 
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LV Schematic 

 
 
Electrical Layout Plan At Level GF, L01, L02, L03 
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Electrical Layout Plan At Level L04-L15, RF, URF, TRF 

 
 
Lighting Layout Plan at Level GF, L01, L02, L03 

  



 

108 

Statutory Subm
ission Sam

ple 

Lighting Layout Plan at Level L04 - L15, RF, URF, TRF 
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10.5 Application for Gas Installation 
Town Gas Layout 
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10.6 License for Generator 
Memergency Generator Room Layout and Sectional Details 
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10.7 Lift & Escalator Inspection 
General Notes, Legends, Abbreviation, and Drawing List 

 
 
L&S Layout Plan at Level GF, L01, L02, L03 
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L&S Layout Plan at Level L04-L15, RF, URF, TRF 

 
 
Lift Shaft Plan Detail & Section 
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Escalator Plan Detail & Section 
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10.8 Transformer Room / LV Switch Room Inspection 
Transformer Room Layout at Level GF 

 
 
L.V Switch Room Layout at Level GF 
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10.9 Telecommunication 
TBE Room Layout at Level GF 
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11 Exporting Models as Deliverables 

11.1 Exporting 3D models as Industry Foundation Classes 
(IFC) 
Users can export the Revit model to IFC format. The IFC file format is a platform-neutral format 
used to allow interoperability between industry BIM programs. 
 
Click “File” ➜ click “Export” ➜ select “IFC” ➜ define the file name and IFC version ➜ “Export’ 

 
Details refer to Revit IFC Manual – Detailed instructions for handling IFC files (Autodesk Inc., 
2018) 
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11.2 Exporting 2D models as PDF 
 
Publishing to 2D can create either a single view or a whole collection of interconnected views and 
sheets packaged as one file. 
 
Click “File” ➜ click “Print” ➜ define “Printer”, “Properties”, “File Location”, “Print Range” and 
“Settings” ➜ click “OK” to publish PDF. 
 

 
 
It is recommended to pre-set print setup for several sizes to standardise and enhance the 
efficiency. 
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12 BIM Auditing 

All models and deliverables shall be audited regularly and before each submission. 
 
An Autodesk Plugin, namely “BIM Interoperability Tools for Revit” could facilitate part of the BIM 
Auditing checking. Some auto data retrieval rules can be pre-set through the Autodesk Model 
Checker.  
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Report can be generated for the selected models according to the listed checking items. 
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13 Reference 

 
1. Revit IFC Manual – Detailed instructions for handling IFC files (Autodesk Inc., 2018) 
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Feedback Form 
 
CIC User Guide for using BIM in Generation of MEP Digital Drawings for Statutory Submissions – Revit 
 
To improve future editions of this publication, we would be grateful to have your comments.  
  
(Please put a "" in the appropriate box.) 
1. As a whole, I feel that the publication is:  Strongly  

  Agree 

Agree Neutral Disagree Strongly 
Disagree 

Informative      
Comprehensive      

Useful      
Practical      

2. Does the publication enable you to 
understand more about the subject? 

Yes No No Comment 

   
3. Have you made reference to the publication 

in your work? 
Quite Often Sometimes Never 

   
4. To what extent the publication benefits you? Strongly   

  Agree 

Agree Neutral Disagree Strongly 
Disagree 

Supply chain Information/data integrity      
Work efficiency      

Project Collaborations      
5. Overall, how would you rate our publication? Excellent Very Good Satisfactory     Fair     Poor 

     
6. Other comments and suggestions, please specify (use separate sheets if necessary). 
  
Personal Particulars (optional):* 
Name:   Mr. / Mrs./ Ms./ Dr./ Prof./ Ar / Ir / Sr ^ 
Company:  
Tel:  
Address:  
E-mail: 
 

 
* The personal data in this form will be used only for this survey. Your data will be kept confidential and dealt with only 

by the Construction Industry Council. 
^ Circle as appropriate. 
  
Please return the feedback form to: 
CIC Secretariat – BIM 
E-mail:              bim@cic.hk; 
Address:           38/F, COS Center, 56 Tsun Yip Street, Kwun Tong, Hong Kong 
Fax No.: (852) 2100 9090 
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