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CHAPTER 1. INTRODUCTION OF BIM 

1.1 WHAT IS BUILDING INFORMATION MODELING (BIM)? 
Building Information Modeling (BIM) is an information-rich, model-centric process 
with the power to transform project delivery and add value across the lifecycle of 
infrastructure assets.  

 
As BIM is adopted by more and more companies in the construction industry, its 
usefulness has expanded beyond the original design phase activities. This course 
positions BIM in the context of all phases of construction illustrating how to maximize 
BIM as a tool for the entire construction team. We will see how BIM fits into the 
construction workflow. It introduces the BIM philosophy in design, bidding, 
construction, commissioning, delivery, and as-built stages of construction.  
Use of BIM goes beyond the planning and design phase of the project, extending 
throughout the whole building life cycle, supporting processes including cost 
management, construction management, project management, facility operation 
and demolition. 
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In traditional architectural design and documentation procedures, drawings are the 
result of carefully reasoned thought and design. Whether we are an architect, an 
interior designer or a draftsman, we spend a lot of our time looking at plans, sections, 
and elevations. A process of draw, erase, and redraw eventually leads to the 
desired result, which then must be replicated in all appropriate drawings, like 
sections and elevations. Each drawing conveys only a small abstracted part of the 
whole and can easily get out of sync.  
Revit is one of common used BIM system in AEC field. In contrast, the BIM/Revit 
workflow, all modifications are performed directly in the model, in any view that is 
convenient to the task at hand. Revit views are live representations of the model 
displayed through the prism of conventional architectural drawing types like plans, 
sections, and elevations. Work that we do and plan is immediately reflected in 
elevation section and vice versa. Revit makes it easy to keep all our changes 
coordinated with a firsthand look at what it is one of the most fundamental benefits 
of building information modeling, the fully coordinated building model. As shown in 
below figure, we can here different 3D views and a floor plan, an elevation, and 
even a schedule. 
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1.2 BIM APPLICATIONS 
The BIM uses throughout the planning, designing, construction and operation stages 
of building life cycle.  
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BIM is not a 3D model 
 
Basic Elements  
1st D (data)  
–  The text, the equation, the parametric, the 

hyperlink  
2nd D (drawing)  
–  Circles, Lines to represent the conceptual / 

relationship between difference components  
3rd D (models)  
–  From subtractive to additive modelling to 

digital  
 
 
The models created for BIM are not just 3D geometry; they are data-rich objects 
which are:  
 

Intelligent 
Parametric engines help define relationships between objects and keep changes 
consistent and coordinated. 
 

Visual  
Enable better analysis, simulation and communication 
 

Putting big data in context 
BIM helps to collect, analyze, and aggregate the huge amounts of data necessary 
to connect designs to the context of the surrounding environment. 
 

Collaboration 
The AEC industry is moving toward integration of disciplines. The collaborative mode 
will become a standard approach. Only advanced data-sharing technology will 
enable effective communication. 
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1.3 NEW WORKFLOW 
BIM is an approach not a technology. It does require suitable technology to be 
implemented effectively. The use of BIM is only 20% technology, but 80% 
management restructuring. 
Building Information Workflow: Model ➤ Modeling ➤ Management 
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CHAPTER 2. UNDERSTANDING REVIT ELEMENTS 

2.1 ABOUT REVIT FAMILY 
All Revit elements are Familis. Families are components you use to build your model, 
such as walls, windows, stairs, doors, etc. Each family can have multiple types, such 
as different size, materials, parameter variables, etc.  Any change to a type is 
updated in every instance throughout the project. For example, when you change 
the window height of one of your window type, all the windows with the same 
window type are updated instantly.  
 
 

 
 
 
Revit Element Hierarchy can be shown as follows: 
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Revit classifies elements by categories, families, types, and instances. 
Category: A Category controls the organization, visibility, graphical representations, 
and scheduling options of Families within the Project. 
 
Family: A Family is a grouping of 2D and/or 3D information that serves to represent a 
discrete building or documentation element in the Project. It defines parametric, 
graphical, and documentation requirements. 
 
Type: A Type is a specific representation in a Family defined by distinct parametric, 
graphical, and  
 
Instance: An Instance is an individual representation of a Type in the Project defined 
by unique parametric, graphical, and documentation characteristics which makes 
it unique from other Instances in the Project. 
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2.2 SYSTEM FAMILY AND LOADABLE FAMILY 
There is a list of predefined families that are shipped with Revit software. However, 
you can also download or create your own family as follows: 
 

System Families 
System families are created inside a project. They contain family types that you use 
to create basic building elements in your building models 
 

Revit includes many system families 
 Ceilings  
 Curtain Systems  
 Curtain Wall Mullions  
 Ducts  
 Flex Ducts  
 Flex Pipes  
 Floors  
 Fluids (an MEP family)  
 Model Text  
 Pipes  

 Railings  
 Ramps  
 Repeating Detail  
 Roofs  
 Site (Pad)  
 Stairs  
 Structural Foundations  
 Structural Loads  
 Structural Rebar  
 Walls 

 

Loadable families  
Standard component families can be created and edited in the family editor. 
Loadable families include diffusers, dampers, valves, tags, and so on. They are 
saved in separate files in “.rfa” files. 
 

Some of standard loadable families for MEP
 Casework  
 Columns  
 Curtain Panel by Pattern  
 Curtain Wall Panels  
 Electrical  
 Entourage  
 Furniture  
 Furniture System  
 Lighting  
 Mass  
 Mechanical  
 Openings  
 Planting  

 Plumbing  
 Railings  
 Site  
 Specialty Equipment  
 Sustainable Design  
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2.3 ABOUT MEP COMPONENTS 
2.3.1 About System  

Systems represent the transfer of information between families. Creating systems in 
MEP project is a key step in automatically generating routing, sizing duct/pipe, and 
performing engineering calculations and analysis in the design. When a system be 
created, a logical relationship is created between related elements in a project. For 
example, a supply air system might include duct, fitting diffusers and mechanical 
equipment. Element s with connectors, such as air terminals and equipment are 
assigned a system classification. 
 
Without systems, ducts and pipes act only as connections between two points. 
Systems are needed to generate the bigger picture and allow you to manage the 
elements on a building-wide level. Systems enable you to build more than just a 
three-dimensional model; they enable the engineering to be included in the model 
as well.  
 
Systems are also useful in the documentation of a model. Because the systems link 
elements, and their engineering data, across the entire model, tags and other 
properties can be managed quickly and accurately. One example of this is using a 
pipe tag that includes not only the size but also the system abbreviation and, if 
needed, flow rate, velocity, or friction loss within the dust/pipe.  
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2.3.2 System Classification 

System classification are parameter that decided which type of connectors the 
system can connect into.  

Types of system classification are pre-defined in Revit.   

Duct System classification (3 types)    Pipe System classification (11 types) 

 

 The system classification is hard coded in 
Revit MEP. 

 It is not allowed to create or delete any 
system classifications.  

 It is not allowed to change the system 
classification of duct/piping systems. 

 In each project, it should have at least one 
duct system for each for the 3 Duct System 
classifications, and one piping system for 
each of the 11 Piping System 
classifications. 
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2.3.3 About Connectors 

One of the primary differences in creating content for Revit MEP and other Revit 
content is the concept of connectors. All Revit MEP content will need to have 
connectors added to it for it to be useful. 
MEP For BS engineers, all MEP components require connectors to behave with 
intelligence. Components created without connectors cannot participate in a 
system topology. Connectors are primarily logical entities that allow calculating 
loads within a project. Revit maintains information about loads associated with the 
spaces in a project. As devices and equipment are placed in spaces, Revit keeps 
track of the loads based on load type: HVAC, Lighting, Power, Other. The loads 
associated with the spaces can be viewed in the instance properties for each 
space, and displayed in schedules.  

 
 

There are five basic types of connectors that can be added to a MEP family 

 
 

Duct connectors are associated with ductwork, duct fittings, and other elements that are 
part of the air handling systems.  
Electrical connectors are used for any type of electrical connections, including power, 
telephone, alarm systems, and others.  
Pipe connectors are used for piping, pipe fittings, and other components that are meant 
for transmitting fluids.  
Cable tray connectors are used for cable tray, cable tray fittings, and other 
components that are meant for wiring.  
Conduit connectors are used for conduit, conduit fittings, and other components that are 
meant for wiring. A conduit connector can be an individual connector or a surface 
connector. The individual connector is used for connecting only one conduit. The surface 
connector is used for connecting more than one conduit to a surface.  
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CHAPTER 3. GETTING STARTED 

3.1 START A PROJECT 
Unlike any other WINDOWS application or a CAD application, Revit does not use the 
term called 'FILE'. Instead, it uses 'PROJECT'.  
The project contains all the information related to the building design, from concept 
to completion. By using a single project file, Revit makes it easier to alter the design 
and have changes reflected in all associated views (plan views, elevation views, 
section views, schedules and so on). Having only ONE project file also makes it easier 
to manage the project (Although, increases the file size.) 
 

3.1.1 Creating a new project  

1. Click on “New” and you can click the default “Architectural Template”. 
2. In the New Project dialog, under Template File, browse to a template file (*.rte). 
3. Normally, we work with metric units, so choose the template from US Metric. 
4. Revit includes a default template called “DefaultMetric.rte”, which contains 

several default settings to help you begin the design process immediately.  
5. Select “Mechanical –Default_Metric.rte” if you want to start a BSE project.  
6. You can also create your own template with the desired settings and standards.  
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3.2 USER INTERFACE 
When you will open the software for the first time, it may look like this: 

 

 
It is important to understand the names mentioned below from the interface as it will 
be referred in the following chapters as well as in the HELP menu of the software or in 
other resources related to Revit. 
Tips: 
Please note… Unlike AUTOCAD or other CAD applications, REVIT does not use 
COMMAND ROMPT. 
Instead, the interface is made of a ribbon with tools & menus. 
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3.2.1 Application Menu 

Click  to open the application menu 

As a shortcut, to click the main buttons in the application menu (on the left) to 
perform the default operation. 

 

 

3.2.2 Quick Access Toolbar 

The Quick Access toolbar contains a set of default tools. You can customize this 
toolbar to display the tools that you use most often. 
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3.2.3 Ribbon 

The ribbon displays automatically when you create a new file or open an existing file. 
It comprises of tabs and panels (see the image above). Tabs are classified by 
functionality of our model. You may find all panels and tools required for 
annotation/notes such as Text, Dimension, etc in 'Annotate' tab. Similarly, all tools 
required for modifying a model are arranges in 'Modify' tab.   

 
As we resize the window, we may notice that tools in the ribbon automatically adjust 
their size to fit the available space. This feature allows all buttons to be visible for 
most screen sizes. 
 
1. Button: Clicking on a button will get you started with the tool; 
2. Drop-down button: contains a drop-down arrow that displays additional tools; 
3. Settings button: invokes a frequently used tool and displays a menu that contains 

additional settings. 
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3.2.4 Expanded panels  

An arrow next to a panel title indicates that we can expand the panel to display 
related tools and controls. 

 
By default, an expanded panel closes automatically when we click outside the 
panel. To keep a panel expanded while its ribbon tab is displayed, click the push pin 
icon in the bottom-left corner of the expanded panel. 

   
Some panels allow us to open a dialog to define related settings. A dialog-launcher 
arrow on the bottom of a panel opens a dialog. 
 

3.2.5 Contextual Ribbon Tab 

When you use certain tools or select elements, a contextual ribbon tab appears. This 
contains set of tools that relate only to the context of that tool or element. For 
example, when you click the Wall tool, the Place Wall contextual tab displays, 
showing a few panels: 

 

We can specify whether a contextual tab automatically comes into focus or the 
current tab stays in focus. We can also specify which ribbon tab displays when we 
exit a tool or clear a selection. 
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3.2.6 Project Browser 

The project browser is one of the most important and frequently used parts of the 
interface. It is used for navigating between different views inside the project. The 
project browser shows a logical sequence for all views, schedules, sheets, families, 
groups, linked Revit models, and other parts of the current project. As you expand 
and collapse each branch, sub-views are displayed. 
-  To go to a particular view, double click its name in the project browser. The active 

view name displays in bold letters. 
-  You can also right click on the view name and click rename. 
-  To delete a view, right click on the view name and click delete. 
-  To show the Project Browser, click View tab ➤ User Interface panel, and select 

the Project Browser check box. 
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3.2.7 View Control Bar 

View Control Bar is located at the bottom of the Revit window above the status bar.  
 

 

 A B C D E F G H I J K L M N O 
 
 
It provides quick access to functions that affect the drawing area, including the 
View scale, Detail level, Model graphics style, shadows on/off, crop region on/off, 
crop boundaries, etc. We shall study them in detail further in our later chapters. 
 

A. View Scale 
B. Detail Level 
C. Visual Styles 
D. Sun Path Toggle 
E. Shadows Toggle 
F. Show Rendering Dialog 
G. Crop View Toggle 
H. Show/Hide Crop Region 
I. Temp Hide/Isolate 
J. Reveal Hidden Elements 
K. 3D View Lock 
L. Worksharing Display 
M. Temp View Properties 
N. Analytical Model Toggle 
O. Highlight Displacement Sets 
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3.2.8 Palette On/Off 

If we subsequently close any palette, we can reopen it by 
 

  Click View tab ➤ Windows panel ➤ User Interface drop-down  
 

 

 

3.2.9 Basic Tools 

Modify Tools (Move, Copy, Align, Offset, Mirror, Rotate) 

 

Move: Select the object, click ; or M+V 

Copy: Select the object, click ; or C+O 

Align: Click , select the reference element, select one or more elements to align 
with the reference element; or A+L. 

Offset: Select the object, click , input the amount of offset, select the object, 

and click at the side you want; or O+F. 

Mirror: Select the object, click , and select the mirror plane; or M+M. 

Rotate: Select the object, click , and input the angel; or R+O. 
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3.2.10 Useful Shortcuts 

1. Zoom In/Out: Directly use wheel on your mouse. 
2. Temporary Hidden Objects: Select objects. Type “HH” on keyboard.  
3. Show temporary hidden objects: Type “HR” on keyboard. 
4. Rotate view. Hold “Shift” button and wheel of your mouse. 
5. Hidden Object: Select objects, right click-➤Hide in View. 
6. Set objects visibility/Override: Type “VV/VG” on your keyboard. 
7. Tile views: Type “WT” on your keyboard. 
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CHAPTER 4. LEVEL AND GRID 

4.1 CREATING/MODIFYING LEVELS 
Go to Project Browser and double click on the section/elevation view to add 
levels.   
1. Click Architecture tab ➤ Datum panel ➤ Level. (Keyboard shortcut 'LL') 
2. Place the cursor in the drawing area and click.  
Note: As you place the cursor to create a level, if the cursor aligns to an existing level 
line, a temporary vertical dimension displays near the cursor. 
3. Draw level lines by moving the cursor horizontally.  
4. Click when the level line is of correct length.  

 
You can also use Ctrl+C of an existing level, Ctrl+V and entering level height to 
create a new level. 
These two methods are faster and simple way to create new level lines. 
 
To change the elevation of the level line: 
Click on the existing level line ➤ Click on the elevation of the level displayed in blue 
color below the name ➤ Write a new elevation value for the Level. The position of 
the level will change according to the new dimension.  
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To rename the level: 
Click on the existing level line ➤ Click on the name of the level displayed in blue ➤ 
Write a new name for the Level. If you rename the level, the associated name for 
the floor plan and the reflected ceiling plan update as well. Thus, you can also use 
the Project Browser to rename the level, if desired. Click on the name of floor 
plan/ceiling plan displayed in project browser ➤ Right click and select rename ➤ 
Write a new name for the floor plan. Corresponding level name will also change.  
 
To switch visibility of level symbols: 
It is possible to have level symbols on both ends or either of the end of the level line.  
To control the visibility of these symbols, select the level line ➤ click on the Box 
besides the level symbol. Check to see the symbol and uncheck to hide it. 

 

 

4.2 CREATING/MODIFYING GRIDS 
Use the Grid tool to place structural grid lines in the building design. You can then 
add columns/structural components along the column grid lines.  
 

Adding Grids: 
1. Open Plan view and Click Architecture tab ➤ Datum panel ➤ Grid.  
  (Keyboard Shortcut 'GR') 
2. Click Place Grid tab ➤ Draw panel, and select a sketch option.  
3. Go to the drawing area and draw the grid line from its starting point to its end  
  point.  
 

Revit automatically numbers each grid. To change the grid number, click the 
number, enter the new value, and press ENTER. You can use letters for grid line values. 
If you change the first grid number to a letter, all subsequent grid lines update 
appropriately.  
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As you draw grid lines, the heads and tails of the lines can align to one another. If 
grid lines are aligned and you select a line, a lock appears to indicate the alignment. 
If you drag the blue drag point of any one grid line, other aligned grid lines will also 
move with it. If you wish to drag only one of the grid line than click on the lock again 
to unlock it and then drag again. 

 

 
 
 
 
Customizing GRID Lines: 
You can customize grid types in the following ways:  
 Change the line color, weight, and pattern 

of the entire grid line:  
Input the desired properties in Type 
properties of the GRID ➤ end segment 
weight / color/ pattern. 

 Hide center segment of grid lines to create 
a gap, displaying only the end segments in 
views: 
Go to Type Properties of GRID ➤ center 
segment ➤ input None.  

 Display the center segment of the grid line 
using a different line color, weight, and 
pattern: 
Go to Type Properties of GRID ➤ center 
segment ➤ input Custom. Center segment 
weight/ color/ pattern titles appears. Input 
the required data. 

 To change the design, fonts and shape of the Grid Symbol, a new family of Grid 
Head needs to be created. It cannot be changed from the properties. 
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CHAPTER 5. LINK PROJECT 

5.1 ABOUT LINKING MODELS 
Linking models is primarily intended for linking separate part of buildings, such as  
Architecture, Structure, and MEP models.  
 

5.2 LINK A MODEL INTO CURRENT PROJECT 
 Click Insert tab ➤ Link panel ➤  (Link Revit).  
 In the Import/Link RVT dialog, select the model to link.  

 

Select “02 Link 2F.rvt”, choose “Auto - origin to origin” as positioning method. Click 
open and model will link into current project. Check if the coordinate is correct. 
After linked the model into project, manual place it to the correct position by using 
move, align tools. 
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The three automatic options are more commonly used, and each has a specific 
function: 
Auto – Center To Center This option links the model from its center point to the center 
point of your project. The center point is determined by the location of the model 
objects within the file.  
Auto – Origin To Origin This is the best option to use unless a shared coordinate 
system is required. The origin of the linked model will not change if the model 
changes size or shape, or even if building geometry is moved or rotated, so you will 
be able to stay coordinated with the building when major position changes occur. 
Auto – By Shared Coordinates This option should be used when a project requires 
that common location coordinates be used. This is most commonly used on projects 
that have multiple buildings because it enables you to keep the relationship 
between buildings coordinated. If you link in a project that is using shared 
coordinates, you can use the same coordinates for your model. 
 

5.2.1 Link Property 

Manage ➤ Mange Links 
After creating a link to a CAD format, DWF markup, or Revit model, you have several 
options for controlling those links. In this dialog, all link/import files are shown, the 
linkage property can be modified here.  
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5.2.2 Reference Type 

Reference Type has two types: Overlay and Attachment. 
When you import a model that contains linked models, the nested links display 
according to the Reference Type setting in their parent model.  
The following image shows that Project A is linked into Project B (so Project B is the 
parent link for Project A). The Reference Type setting for Project B is Overlay, 
therefore when Project B is imported into Project C, Project A does not display.  

 

If you change the Reference Type setting for Project B to Attachment, when you 
import Project B into Project C, the nested link (Project A) displays.  
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5.3 ABOUT LINKING CAD 
Main functions to used linking CAD files as follows:  
 the details or elevations drawings, which created by AutoCAD, are linked into 

the project and place them on sheets. These drawings can then be included in 
the set of construction documents that Revit generates.  

 To link AutoCAD drawings from other disciplines to a project to use them as 
underlay for your project views.  

 

Linking CAD could maintain a connection between an AutoCAD file and a Revit 
project. Revit maintains a link to that file. Whenever the project open, Revit retrieves 
the current, saved version of the linked CAD and displays it in the project. Any 
changes to the linked file are displayed in the project.  
 
When you link (or import) an AutoCAD file to a project, you can do the following:  
 Query objects in the file.  
 Hide or delete selected layers in the file.  
 Preserve or discard graphic overrides for linked files.  
 Make global changes to the graphic display of layers.  
 Make view-specific changes to the graphic display of layers.  
 
When you link a file to a project, you can control whether the linked file is visible only 
in the current view, or in all views. As a 2D drawing, the linked file is displayed only in 
relevant 2D Revit drawings, such as floor plans. In a 3D view, the linked file is 
displayed as flat, 2D shapes.  
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CHAPTER 6. COPY/MONITOR MODELS 

When multiple teams collaborate on a project, effectively monitoring 
and coordinating work can help to reduce mistakes and expensive rework. Use the 
Copy/Monitor tool to ensure that design changes are communicated across teams. 
 

Click Collaborate tab Coordinate panel Copy/Monitor drop-down 
 (Select Link). Click  (Copy). 

 

When you select a copied level, the monitor icon      displays next to it to indicate 
that it has a relationship with the original level in the linked model. 

 
After you establish relationships between elements using the Copy/Monitor tool, you 
can perform a coordination review to view and address any warnings generated by 
changes to those elements. 
 

Click Collaborate tab Coordinate panel  Select Link 
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CHAPTER 7. ANNOTATION 

7.1 SPOT ELEVATIONS 
Spot elevations display the actual elevation of a selected point. Spot elevations can 
also display the top and/or bottom elevation of elements with a thickness. Top and 
bottom elevations are available for elements in plan views. 

 
You can place spot elevations on non-horizontal surfaces and non-planar edges. 
You can place them in plan, elevation, and 3D views. Spot elevations are typically 
used to obtain a point of elevation for ramps, roads, topo surfaces, and stair 
landings. 

 

Spot Coordinates 
You can display the elevation of the selected point and indicator text in addition to 
the coordinates. 

 
Coordinates are reported with respect to the shared coordinate system. 
Spot coordinates can be placed on floors, walls, topo surfaces, and boundary lines. 
You can also place spot coordinates on non-horizontal surfaces and non-planar 
edges. When you display the elevation of the selected point in addition to the spot 
coordinates, you can place the spot coordinate in the same locations you can 
place a spot elevation. 
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7.2 DIMENSIONS 
Dimensions are view-specific elements that show sizes and distances in a project. 
There are 2 types of dimensions: temporary and permanent. 
Revit places temporary dimensions as you place components. You create 
permanent dimensions to define a particular size or distance. Each dimension type 
can be modified, and the component that is dimensioned updates accordingly. 

 

Changing Temporary Dimensions to Permanent Dimensions 
1. Select a component in the drawing area. 
2. Click the dimension symbol that appears near the temporary dimension. You 
can then modify the properties of the new dimension and change its type. 
 
Dimension Tools allows you to pick either individual references (default) or entire 
walls. When the Entire Walls option is selected, click the Options button to modify the 
Auto Dimension settings. In this example, we have chosen to dimension opening 
widths as well as intersecting walls. The dimension string shown was placed with a 
single click on the exterior wall!  
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7.3 USING TEXT 
The text object consists of a resizable field into which you can enter text with 
optional features including leaders, bullets, or numbers.  
 
1 Click Annotate tab Text panel  (Text).  

 The cursor changes to the text tool .  

2 On the Format panel, select a Leader line option:  
  No Leader (default)  
  One Segment  
  Two Segments  
  Curved - to change the curve shape, drag the elbow control.  

 

  

 

Grips  
The round grips on either side of the text box allow you to resize the width of the box. 
Move  
There is a move icon that appears in the upper-left corner of the text box.  
Rotate  
The upper-right corner shows a rotate icon. Clicking this icon allows you to rotate the 
text box as you would any object in a project.  
 
 
 
 



Building Information Modelling ‐ Building Services 

 

Page 24 

7.4 ABOUT TAGS 
Tags can be created for any category of Revit model element to report information 
about the element on sheet views. A tag is 2D annotation family, which can contain 
a combination of labels and linework, much more useful than plain text. Labels 
update automatically when the parameters of an element are changed.  
 

 
 

In addition, we can load multiple tags for every category family. 
 

7.4.1 Tag by Category 

Use the Tag tool to attach a tag to a selected element. A tag is an annotation for 
identifying elements in a drawing 

Annotate tab ➤ Tag panel ➤  (Tag by Category)  
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7.4.2 Tag All Not Tagged 

If some or all elements in a view do not have tags, you can apply tags and symbols 
to untagged elements in one operation.  
 
If you do not select elements, the Tag All Not Tagged tool 
will tag all elements in the view that are not already 
tagged.  

 Click Annotate tab ➤ Tag panel ➤  Tag All.  

 
 
 
 
The Tag All Not Tagged dialog displays. 
 

 Specify the elements to tag.  
o To tag all visible elements in the current view that do not have tags, select All 

objects in current view.  
o To tag only those elements you have selected in the view, select Only 

selected objects in current view.  
o To tag elements in linked files, select Include elements from linked files.  

 Select one or more tag categories.  
o By selecting multiple tag categories, you can tag different types of elements 

(such as detail items and generic models) in one operation.  
o To select multiple categories, while pressing Shift or Ctrl, select the desired 

categories.  
 Select Leader to attach a leader to each tag 

o For Leader Length, enter a default leader length.  
o For Tag Orientation, select Horizontal or Vertical.  

 



Building Information Modelling ‐ Building Services 

 

Page 26 

CHAPTER 8. ABOUT PLAN VIEWS 

In a 2D view, Revit provided to display a floor plan, a reflected ceiling plan, or 
structural plan.  
The floor plan, reflected ceiling plan (RCP) and structural plan view are the default 
view in a new project which depend setting in project template. Plan views are 
created automatically as you add new levels to your project. 
 
Floor Plan Views 

 
Reflected Ceiling Plan Views 

 
Structural Plan Views 
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8.1 CREATE AN ELEVATION VIEW 
Use elevation views to look at a project from different locations, either exterior or 
interior. 
Click View tab Create panel Elevation drop-down  (Elevation) 
 
To set different interior elevation views, highlight the square shape of the elevation 
symbol, and click. The elevation symbol displays with check box options for creating 
views, as the following image shows. 
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8.2 CREATE A SECTION VIEW 
Click View tab Create panel  (Section). 
Click when you reach the end point of the section. The section line and the crop 
region appear and are selected. 

 

To open the section view, double-click the section header, or select the section 
view from the Sections grouping of the Project Browser. 
The section view changes when the design changes or the section line is moved 
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8.3 CREATE A CAMERA VIEW 
Click View tab Create panel 3D View drop-down    Camera. 
 
Click once in the drawing area to place the camera, and click again to place the 
target point 
 

In 3D View > Select  "Full Navigation Wheels" 

You can use Full Navigation wheels for both viewing an object and touring a 
building.  
 

   

 

8.4 CREATE SECTION BOX 
Use a section box to define the part of the 3D view to export 
 
Go to 3D View, In Properties > Extents > Tick "Section Box" 
You can cut the model by using the section box 
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8.5 ORIENT A 3D VIEW 
Using the ViewCube, you can orient a 3D view to any plan, elevation, section or 3D 
view in the project.  

 
 
To orient a 3D view to another view: 
1. In a 3D view, right click the ViewCube. 
2. Select Orient to View and then select the view type and name. 
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CHAPTER 9. VIEW PROPERTIES 

9.1 EXPLORING VIEWS AND MODIFYING VIEW PROPERTIES 
On a view, without selecting anything, the property shows the view properties of 
current view.  
 

9.1.1 View Range 

Within the view properties of any plan view, 
you can set the View Range. With View 
Range, you can control the specific 
geometric planes that define the boundaries 
of each view. These boundaries are set by 
defining the exact cut plane as well as the 
top and bottom clip planes. 
Every plan view has a property called View Range, also known as a visible range. 
The view range is a set of horizontal planes that control object visibility and display in 
the view. The horizontal planes are Top, Cut Plane, and Bottom. The top and bottom 
clip planes represent the topmost and bottommost portion of the view range. The 
cut plane is a plane that determines at what height certain elements in the view are 
shown cut. These 3 planes define the primary range of the view range. View depth is 
an additional plane outside of the primary range. You can set the level of view 
depth to show elements below the bottom clip plane. By default, the view depth is 
coincident with the bottom. 
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9.1.2 Depth Clipping 

Make view adjustment to view parts of a model below the cut plane.  
To activate this feature using the Depth Clipping parameter for the plan view. The 
back clip plane is defined by the View Depth parameter, which is part of the view’s 
View Range properties. Plan views include floor plan views, reflected ceiling plan 
views, detail plan views, and callout plan views.  
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9.1.3 Object Visibility 

Click Edit on Visibility/Graphic. Or click “VV” on keyboard. Open a window like 
bellows, 

 
 Highlight a category row. Click the Override button for the line or pattern to edit. 
 Click Apply to view your changes, and click OK to exit the Visibility/Graphics 

dialog. 
 
For annotation and imported categories, you can only override projection and surface 
display. 
 

For lines, edit the line weight, line color, and line pattern.  
 

For patterns, edit the fill color and fill pattern. (Optional) Select the Halftone check box next 
to a category to blend the line color of an element with the background color of the view. 
This produces a lighter shade for the line color.   
 

For model categories, you can also select a detail level at which to display the element 
category. The detail level of the category overrides the detail level of the view. For example, 
you can set a wall to display at medium or fine detail level to see its structure, even if the 
view detail level is set to coarse. You cannot set the detail level for subcategories. They 
inherit it from their parent category.   
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9.2 CREATING A FILTER 
1. Click View➤ Filters. Open a dialogue like follows,  

 
If you are creating a new filter, in the Filter Name dialog, enter a name for the filter. 
If you are duplicating an existing filter, the new filter displays in the Filters list.  
To rename the filter, click the name, and click  (or right-click the name, and click 
Rename).  
2. Under Categories, click one or more categories to include in the filter. The 

categories that you select determine the parameters that are available in the 
Filter By lists. For fresh air duct, the category will select Duct, Duct Fitting and Air 
Terminal. 

3. Under Filter Rules, Select the filter operator from the following options:  
 Equals. The characters must match exactly. 
 Does not equal. Excludes everything that does not match the value you enter. 
 Is greater than. Looks for values greater than the value you enter 
 Is greater than or equal to. Looks for values greater than or equal to the value you 

enter.  
 Is less than. Looks for values less than the value you enter  
 Is less than or equal to. Looks for values less than or equal to the value you enter.  
 Contains. Selects a character anywhere in a string. 
 Does not contain. Excludes a character anywhere in a string. etc 
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Here, we use Comments Equals to FAD to filter the fresh air duct and air terminal. 
Select Duct and Duct Fittings from categories and define Filter Rules, Comments 
Equals FAD. 

 

9.3 APPLYING A FILTER 
After create filters, open a plan view or 3d view, use keyboard click VV. 
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Click Add. Open the dialogue like this.  

 
Select the filter or add new filters. Click ok and set the colors and pattern. 

9.4 CREATING A FILTER TEMPLATE 
Click View ➤ View Templates drop-down. 
The View Templates dialog displays. 

 

Tip: If a view has been set up all the filters, this template will remember its setting. 
When applying template to other view, the filter will automatically change to 
template filter setting.  
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9.5 CREATING A SCOPE BOX 
Use a scope box to specify the views in which the datum elements will display.  
When you add grids, levels, and reference lines to a project, they can display in 
more views than desired. For example, when you add grid lines to a plan view, the 
grid lines display in all plan views of the model. However, you may want the grid lines 
to display in only certain views.  

 
You create scope boxes in plan views only. After a scope box is created, you can 
change its size and position in a 3D view. 

1.  In a plan view, click View tab ➤ Create panel ➤  (Scope Box).  

2.  On the Options Bar, enter a name and specify a height for the scope box, if 
desired.  

3.  To draw a scope box, click in the upper left-hand corner to start the box. Click in 
the lower right-hand corner to finish it. 

4. When you draw a scope box, it displays drag controls, which you can use to 
resize the scope box. You can also rotate the scope box using the rotate control 

and the Rotate tool .  
Tip: You can also change the name of the scope box after creating it. Select the 

scope box, and on the Properties palette, enter a value for the Name property. 
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CHAPTER 10. CREATION OF BILL OF MATERIALS 

10.1 ABOUT SCHEDULE 
One of the uses of BIM, and increasingly a deliverable, is that what is on drawings 
matches what is in schedules. Revit can provide overviews of various information 
contained in the model.  
 
The creation of bill materials can be achieved by the function of Quantity Schedule 
and Material Take-off Schedule.  
 Quantity Schedule can count any data from the model. It can be wall schedule, 

to show wall length, wall area, or wall volume. Revit can calculate values for you 
in these schedules, based on the properties of model and formulas provided. For 
example, calculate the area and length or count the number of wall. 

 Material takeoff schedules list the sub-components or materials of any Revit 
family. They have all the functionality and characteristics of other schedule views, 
but allow to show more detail about the assembly of a component. Any material 
that is placed in a component within Revit can be scheduled if material is 
applied. 
 

 

10.2 CREATING A QUANTITY SCHEDULE 
 Click View menu ➤ New ➤ Schedule/Quantities, or on the View tab of the 

Design Bar, click Schedule/Quantities. 
 In the New Schedule dialog, select a component from the category list. A default 

name appears in the Name text box, which we can change as necessary. 
 Select Schedule building components. 
 Specify the phase. 
 Click OK. 
 In the Schedule Properties dialog, specify the schedule properties. 
 Click OK. 
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10.3 CREATING A MATERIAL TAKEOFF SCHEDULE 
 Click View menu ➤ New ➤ Material Takeoff. 
 In the Material Takeoff dialog, click a category for the material takeoff schedule, 

and click OK. 
 In the Material Takeoff Properties dialog, for Available Fields, select the material 

attributes. 
 Optionally, sort and group, or format the schedule. 
 Click OK to create the material takeoff schedule. 
 The material takeoff schedule displays, and the view is listed in the Project 

Browser under Schedules/Quantities. 
 

10.4 CUSTOMIZE SCHEDULES 
To create a more workable Schedule it can be useful to format the Schedule. We 
can filter fields, calculate totals, etc.  
In the properties window of the Schedule, by clicking any of the Edit buttons the 
Schedule Properties window opens. 
 

10.4.1 Formatting Schedules 

There are several choices available for formatting the look of the schedule.  
 Specify the order and type of properties to display.  
 Create totals  
 Create your own custom properties, which you can then include in the schedule  
 Apply phases to a schedule  
 Set conditions to apply background color to cells in the schedule in order to 

verify design parameters are met.  
 
In the Fields tab we can change the Fields you would like to use in our Schedule.  
 
In the Filter tab, we can use filters to see only certain types of information in a 
schedule.  

  We can create up to 4 filters, and all filters must be satisfied for the data to 
display.  

  Many types of scheduled fields can be used to create filters. Types include 
text, number, integer, length, area, volume, yes/no, level, and key schedule 
parameters.  
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Filtering is not supported for the following scheduled fields:  
  Family  
  Type  
  Family and Type  
  Area Type (in area schedules)  
  From Room, To Room (in door schedules)  
  Material parameters  
 

In the Sorting/Grouping tab you can sort our Schedule. You can also add blank lines 
between sorted categories. And you can choose to calculate totals. Un-checking 
the Itemize every instance will group the values in a sorted category. NOTE: 
grouping the values will leave some of the values blank. You will need to change the 
Formatting of these Fields (see next part)  
 
In the Formatting tab you can change the formatting of the fields in our schedule. 
The most important item here is the Calculate totals option for some of the fields. 
Checking this option will calculate the totals of grouped values. 
 

10.4.2 To add a calculated value:  

Formulas are used to calculate values (i.e. total costs).  
 

 Click the Calculated Value button and give this value a useful name (i.e. Total 
Cost). Choose the right type of value from the drop down menu (in this case 
Currency).  

 Click the ... button behind the Formula field to see the fields that can be used for 
the formula. Create the formula by clicking the field you want, type the 
mathematical operator (+, -, *, /, etc.), click another field or value, a 
mathematical operator, etc.  

 
Just make sure you end the formula with dividing by 
the number of units (in this example a price per 
meter is used and the length is in mm, so you have to 
divide by 1000. If Cost would be per m2 and you'd 
use the area (areas are in m2) you would have to 
divide it by 1 to get the cost per one wall. 
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10.5 EXPORT TO MICROSOFT EXCEL 
A Schedule can be exported to Excel to do further calculations or exchange data 
with non-Revit users.  
 
 Click the Application Button ➤ Export ➤ Reports ➤ Schedule  
Choose a path and a file name to store the TXT file. 

 

➤ Click Save.  
Leave the settings as they are. 

 
➤ Click Ok.  
 
Open the Schedule in Excel 
File » Open...  
Set Files of Type to Text Files (*.prn;*.txt;*.csv)  
Browse to the location where you saved the TXT file. Select the file.  
Click Open  
Leave all the settings as they are and click Finish  
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CHAPTER 11. PREPARING DRAWING AND SHEET 

11.1 CREATE DETAIL VIEW 
There are 2 main types of views you can create for detailing: detail views and 
drafting views.  
 A detail view contains elements from the building information model.  
 A drafting view is a sheet of paper that is not directly associated with the building 

information model.  

 

 
 
 
 

 

11.2 MANAGE DETAIL LIBRARY 
 Saving a drafting view as a file allows to put it in a location where build a library 

of details and diagrams that can be accessed for use on other projects. 
 Centralize all drafting view into a detail library by insert view from file function. 
 Organize detail library in any manner that suits workflow or processes.  
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11.3 IMPORT CAD 
If you have already done a conceptual design in AutoCAD (or other CAD programs), 
then you can import a CAD file into REVIT.  
Difference between Link & Import 
Linking CAD means the CAD file has a relative relationship with Revit project, when 
CAD drawing is updated, the linked CAD drawing in Revit can be updated 
simultaneously.  
Importing CAD file means the CAD drawing was pasted it directly into the Revit 
model, you can define the visibility of CAD file of its layers. And you can set the 
visibility of CAD drawing in different Revit views. In order to maintain the CAD 
drawing even when the Revit model was relocated, Import tool is suggested. 
 Click Insert ➤ Import CAD ➤choose the CAD drawing from browse.  

 
 

 

CAD Details 
 One of the primary benefits of Revit is the ability to reuse CAD drawings. Making 

the transition to Revit can use CAD details and diagrams in your Revit projects, 
and re-create in Revit format to build a new library of details for use on projects.  

 Converting CAD details to Revit reduces the number of CAD files have to link into 
projects, which helps improve file performance. 
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11.4 CREATE AND PRINT SHEET 
11.4.1 Creating Sheets 

Revit can produce construction documents of the same quality that we have grown 
accustomed to in traditional CAD systems.  

 
 Sheet features that allow to combine a Titleblock and create construction 

documents from model which can include the schedules, details, diagrams, plan, 
section, and elevation. 

 Titleblocks are a unique family type within Revit. A titleblock typically contains 
information about the project in general along with information specific to the 
items shown on the sheet. The most effective way to provide information on a 
titleblock is by using parameters.  

 The use of parameters lets you make changes in a single location that updates 
all of your sheets in the project.  
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11.4.2 Preparing a Sheet 

A sheet can be added one or more views of a building, including floor plans, site 
plans, ceiling plans, elevations, 3D views, sections, detail views, drafting views, and 
rendered views. Each view can be placed on ONE sheet only.  
Note: Legends and schedules can be placed on multiple sheets.  
 
To add views to a sheet 
 Open the sheet.  
 To add a view to the sheet, use one of the following methods:  

o In the Project Browser, expand the list of views, locate the view, and drag it 
onto the sheet.  

o Click View tab ➤ Sheet Composition panel ➤  (Place View). In the Views 
dialog, select a view, and click Add View to Sheet.  

 As you move the cursor over the sheet in the drawing area, a viewport for the 
selected view moves with it. Click to place the viewport in the desired location. 
Use the Align Views on a Sheet for precise placement on sheets. Use Snap to 
Sheet to snap between datums in the model viewport and annotations on the 
sheet.  

 If needed, you can modify the individual views on the sheet as follows:  
o To change the view title that displays on the sheet, double-click the title, and 

edit it.  
o To move the view to a new location on the sheet, select its viewport, and 

drag it. You can align views to grid lines for precise placement.  
 
In additional,  
 Change the scale of the view.  
 Add dimensions to the view.  
 Add text notes to the view.  
 Pan the view.  
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11.4.3 Printing Sheets and Views 

To streamline the printing process, we can create and save print setups for different 
type of print jobs. We can also create and save sets of views/sheets, so it is easy to 
reprint a set later. 
    
 There are so many types of printers and print drivers 

that it would be difficult, if not impossible, to describe 
print settings that would work for everyone on every 
project. The best thing that we can do to make our 
printing tasks easier and more efficient is to take a 
sample project and experiment with different print 
settings until the desired results are achieved. 

 Any of the views in your project can be printed, except 
for schedules. A schedule would have to be placed on 
a sheet so that the sheet could be printed.  

 The Name drop-down list at the top is for saved print 
setups. Once you have established the settings that 
produce the desired print quality, you can save the 
setup for future use. 

 In the Print Range section, choose to print what is currently visible in the drawing 
area or the currently open view, or you can select views and sheets to be printed 

 Filter the list of available views and sheets to show only views or only sheets by 
using the check boxes at the bottom of the dialog box.  

 Once chosen a set of views or sheets, save the selection set for future use.  
 The Name drop-down at the top of the dialog box lists all the saved selection 

sets. 
   

   




